Jump to content
Sign in to follow this  
steel

Fox Relliant Elbil

Recommended Posts

Hej, som tidigare nämnts köpte jag Cealms Fox Relliant.  Den är ombyggd till elbil av Göteborgs Verkstäder någon gång på 80-talet. 20181013_165917.thumb.jpg.ac11ed601d1f9c613ca84527eab9c183.jpg

Det är en kaross i glasfiber med galvad bärande ram. Individuell framvagn med dubbla a-armar samt stel axel bak upphängd i längsgående bladfjädrar. Det satt en dc series motor i den orginal.

20181110_180826.thumb.jpg.58bd5026ff80110b55911e1a1463a1aa.jpg

Den är provkörd med Kelly controllern och ska tillbaka i bilen. Märkeffekten är hårresande 8 kW, men det ska man inte haka upp sig på. Det är Volt samt Ampere man skickar i den som avgör.  

DC motorn sitter direkt på kardanaxeln. 

Det som fattas är batterpack och lite relän.

Här kommer det intressanta i kunskapsresan, ska snäppa upp det lite svårighetsmässigt. Ska nämligen stoppa i några Tesla batterimoduler, DIY BMS från Evtv samt ( hör och häpna) Canbusstyrd Tcc laddare.  

Tänkte bygga ett modulärt batteripack som jag ska kunna stoppa i vad det nu är som ska elektrifieras i framtiden (Gråben 😉).   Elfox har en låda i skåpet som batteripacket är tänkt att passa i. 

Påbörjade konstruktionen av batteripacket idag i väntan på Ali men inte express. 20181110_180836.thumb.jpg.dca60b75cea83a90f756955c52840e0d.jpg

Mvh Pär 

Edited by steel

Share this post


Link to post
Share on other sites

Grå ben knapp tyst .... 

stackars älgar 

  • Like 1

Share this post


Link to post
Share on other sites

😀Japp, LUPUS  ! Nu får älgarna inte det lätt !!

Stoppade i Tesla moduler för att se om jag mätt rätt. Blir 3s2p setup. Mao 3 i serie 2 parallellt.  Ca 70 V , massa A samt ca 30kWh. Går även att konfigurera om packet till solcells batteri bank,  i mitt fall 48V. Kuriosa, idag gav solcellsparken 0,738 kWh, gråtjockt....

20181111_113623.thumb.jpg.40fcda265a82c1058b69239d599af3f8.jpg

Aluvinklarns inpassade, borrade och gängade för fastsättning av moduler. 

20181111_153638.thumb.jpg.36c15bd329f7760d0ba146db33ddfe7e.jpg

Färdigsvetsat med diverse fästen för accessoarer.

20181111_175021.thumb.jpg.9c8808b594b2b7e21b56abeb815333e1.jpg

Mvh Pär.  

  • Like 2

Share this post


Link to post
Share on other sites

Hej, jaha och vem var det som mätte lådan där batteripacket skulle vara ???

Fort och fel 😨20181112_145336.thumb.jpg.a27ec5067969a865528110b6a5dac0ac.jpg

Lådan  är 720 mm innermått, ramen till batteripacket blev 730 mm 😠

Blev sur och tog bort lådan, den var ju ändå felgjord......

20181112_153159.thumb.jpg.add5eadc5c8d59e8aafc30fb2e85dd48.jpg

Mvh Pär 

  • Like 3

Share this post


Link to post
Share on other sites

Hej, har börjat plocka ihop batteripacket. Har målat med hammarlack och popnitat dit en aluminiumplåt i botten.

Skruvade dit fästena för teslamodulerna och började lyfta i modulerna, men konstaterade att det måste vara större diameter på brickorna som ska klämma mot flänsen på batterimodulerna. 

Lade ner verksamheten, satt på mig träningskläder, pannlampa och stack ut och sprang istället🏃20181122_183500.thumb.jpg.a7a0dbf7524a3850c68a2eb72eb3b710.jpg

Mvh Pär 

  • Like 1

Share this post


Link to post
Share on other sites

Hej, pillat vidare med batteripacken.  Tänk vad invecklat allt ska bli jämt. Hel...te va kabel det blir innan det är klart.20181124_203119.thumb.jpg.a355392e8f65cc950c9f966bf806d599.jpg

Mvh Pär 

Share this post


Link to post
Share on other sites

Hej, fortsatte med batteripacket, är nu bara modulerna som ska kopplas in. De har separata BMS: er som kopplas i en "Daisy chain configuration ", de ni 👍20181125_160820.thumb.jpg.60996cc58a2837a02731097b1cffe7d6.jpg

Man är som en hund, springa kan man "nästan"  utan att bli trött, men måste man tänka blir man tvärslut.  Då är det bra med lite Elcrosskart imellan. 

Mvh Pär 

Edited by steel
Jä..a autospell i telefon

Share this post


Link to post
Share on other sites

Hej, har börjat reda ut kablaget för modulernas BMS.  Satt fast molex kontakterna I en pappskiva för att enklare kunna löda och koppla samt få till rätt längd.20181126_193939.thumb.jpg.bff2ed7c9c9d54420e582c3fc4fe3f0d.jpg

Mvh Pär 

  • Like 2

Share this post


Link to post
Share on other sites

KORTSLUTNING 😠😠

Mvh Pär 

Share this post


Link to post
Share on other sites

Nog för att jag är elbilsfrälst men det är detta jag hatar med batterier, de går inte att stänga av när man jobbar...

Blev det stora skador? Hur gick det med dig?

  • Like 1

Share this post


Link to post
Share on other sites

Hej, det gick bra med mig, tack för omtanken. Håller med, det är ett problem att det inte går att stänga av.  Vet ej skadorna, det blev en liten ljusbåge när jag skulle koppla in pluspolen på + kontaktorn.

.446239547_ModuleController3.0-small_medium.jpg.3d3453960243d757d86dad0d80019140.jpg

Fattar inte riktigt varför, har varit väldigt noga med allt kablage. Det enda jag kan tänka mig är att jag vänt DC-DC fel alternativt att laddaaren har några kondingar eller spolar som tar lite ström vid påkoppling. Får luska lite ikväll.

 

Mvh Pär

Share this post


Link to post
Share on other sites

Det lär sitta lite kondensatorer i DC/DC så det kanske inte är några skador alls.

Sitter även laddaren på samma sätt som DC/DC, alltså för kontaktorerna? Den bör också innehålla en bunt kondensatorer.

 

Dock undrar jag varför du placerat DC/DC så att den alltid är inkopplad? Detta kommer att kunna tömma driftbatteriet helt. 

Jag rekommenderar dig att placera den på andra sidan kontaktorerna alternativt med ett eget relä som styrs av strömbrytaren du har på 12V sidan av DC/DC om du vill kunna stänga av den.

Share this post


Link to post
Share on other sites

Du kan koppla in pluspolen på + via ett motstånd så begränsar du inrusningsströmmen och sedan utan att bryta kopplar du in utan motstånd, alltså kortsluter motståndet.

Har du inget lämpligt motstånd borde det funka med en 12V (24V eller högre vore att föredra men nöden har ingen lag...) glödlampa i serie.

  • Like 1

Share this post


Link to post
Share on other sites

Tack, för tipset bexander ! Har några precharge resistorer för 72 volt så det passar ju perfekt !   Låter hoppfullt att dc-dc kanske klarat sig, jag har kopplat den bakvänt. Tankevurpa, hög spänning -grov kabel när det i detta fallet blir tvärtom med A strömstyrkan...

Laddaren sitter efter kontaktorerna. Systemet är tänkt för att nyttja Teslamodulerna som solcellsbatteri, är nog därför dc-dc sitter före kontaktorn, systemet är konstant på. Den varianten av DC/DC jag har sitter det  en extra tändningskabel till dc-dc,  tänkte nyttja den för avstängning.  

Wiring:
Input: 
Red:Input Positive with 15A fuse(2.0mm2)
Yellow: Key Switch(2.0mm2)
Black: Input Negative(2.0mm2)
Output: 
Red: Output Positive(4.0mm2)
Black: Output Negative(4.0mm2

 

Mvh Pär

Share this post


Link to post
Share on other sites

Input är väl på 72V sidan? Liten kabelarea och lägre ström.

Jag är inte riktigt med på vad du menar om att du kopplat den bakvänt.

Jag håller själv på med en laddare med några nätagg i serie, tänkte mig inte riktigt för och vips så har jag sabbat ett nätagg. Roligt med el men när man gör fel får det snabbt konsekvenser. Oftast enklare med mekanik att se att det här är en dålig ide...

Share this post


Link to post
Share on other sites

Bexander, jag kopplade in 72V på utgångssidan dvs mot 12V.  Men DC/DC överlevde 👍 Det är precis som du skriver, ingångsidan klen kabel area där. 

Tipset med med en liten resistor som förladdning funkade perfekt,  stort tack !

Gjorde en liten krets med strömbrytare som jag kopplade in efter säkringen, egen förskruvning, så att det gick att koppla på batteriet utan gnistor ☇☇20181128_174049.thumb.jpg.86151d6e61772f86e50d03d9fc8bdce3.jpg

20181128_175848.thumb.jpg.9ab99aa7805fbd284d797e320f38778c.jpg

Även shunten inköpt på Aliexpress funkade. 20181128_175903.thumb.jpg.9979c988d3608bb82702a81c60a98a51.jpg

Kräver lite kalibrering dock. 

Provade DC/DC aggregatet som funkade trots fabläsen med inkoppling,  men som TUR VAR mätte jag utspänningen innan jag kopplade på övrig utrustning , 24 volt. Har fått fel DC/DC !!  Som du skriver bexander kul med el men väldigt lätt att man eldar upp grejer.  Mekanik är översiktligare. 

Mvh Pär 

 

Share this post


Link to post
Share on other sites

Hej, har nog sabbat DC /DC ändå. Modellen finns bara med 12 V ut. Hmm...

 

Mvh Pär

Share this post


Link to post
Share on other sites

Har du testat spänningen ut från DC/DC med någon last? Halvljuslampa är en billig last.

Share this post


Link to post
Share on other sites

Hej, ska testa det bexander ! Men det får bli nästa vecka, nu är det sociala aktiviteter resten av veckan.

 

Mvh Pär

Share this post


Link to post
Share on other sites

Bygga bil är inte alltid enkelt, T o m jag som bygger enligt 1957 eller 1968 års koncept beroende på hur man ser det, fastnar ibland i tanketräsket ! 😃 

Mvh Kjell 

  • Like 1

Share this post


Link to post
Share on other sites

Hej, ska inte vara lätt Kjelland28, då blir det tråkigt.

Bexander det var som du misstänkte.  Vid last, kopplade dit en ledlampa, då visade spänningen 13,5 V. Helt enligt spec. Tack för det 😀 Men vid inkoppling av ett xenon ljus 40W darrade lampan, dc-dc gav inte så mycket A, konstigt. 

Kopplade på spänning via batteri till mikrodatorn och den hoppade igång som den skulle. Skulle då " BARA " koppla in datorn via USB och det rekommenderade nerladdade terminalprogrammer COOLTERM för att konfigurera systemet och CAN laddaren.  Men tji, "Din dator har ingen com port (serial)"

På mikrodatorn sitter den en USB b skrivar port. Och på min bärbara endast USB. Terminalprogrammet kan endast läsa via serieport.  Har då en adapter med drivrutin för att få till en USB serieport MEN då USB kontakt och serie RS 232 i andra. Har sökt drivrutiner och adapters men icke.

Hur göra ???

Tröttnade och skruvade i elmotorn och controllern i Fox. Kopplade ihop allt kablage och provkörde med 48V batteriet.  DET funkade iaf.20181204_190322.thumb.jpg.5983144b30ef462182ed006e54c5f506.jpg

20181204_190315.thumb.jpg.a45ffeb41623f66aa25fbee339ab4bd9.jpg

Mvh Pär 

Share this post


Link to post
Share on other sites

Får du inte upp usb portarna som com portar alls ? Har du provat med PuTTY istället ? Det borde ju bara vara att koppla in en usb kabel mellan dator och mikrodator välja rätt com kanal och sen ställa in grejerna.

Skickat från min Moto G (5S) Plus via Tapatalk

Share this post


Link to post
Share on other sites

Hej, har testat PuTTY, även det programmet kräver com portar. Får inte upp comportar, bara USB. Kopplade in min adaptersladd och drivrutin,  fick då upp com 4. Snabbt som attan bytte jag till USB-USB B printer och kopplade in, men det hjälpte inte....

Mvh Pär 

Share this post


Link to post
Share on other sites

Vad heter mikrodatorn ?

Skickat från min Moto G (5S) Plus via Tapatalk

Share this post


Link to post
Share on other sites

Vilken typ av USB har du i mikrodatorn?

Skickat från min Moto G (5S) Plus via Tapatalk

Share this post


Link to post
Share on other sites

Hej, det är en "84MHz Arduino Due compatible controller" och det sitter en USB B printerport.  Kanske är nått fel med min laptop men har ju lyckats koppla ihop den med Megasquirt ??controller2_medium.jpg

Mvh Pär

Share this post


Link to post
Share on other sites

Eftersom det är ett Arduino-kompatibelt kort borde du kunna testa med Arduinos egna programvara och se om du får kontakt med kortet, alltså att det är möjligt att välja den porten.

Normalt programmeras Arduino mha serieport så funkar det i Arduino IDE så är det nog en fråga om drivrutiner.

Arduino IDE

  • Like 1

Share this post


Link to post
Share on other sites

Gällande DC/DC så kan något vara trasigt. Dock kan det vara bra att testa med en vanlig glödlampa eller ett motstånd. Ett Xenonljus har väl en drivare som innehåller elektronik vilket kan göra att DC/DC hittar på hyss när den inte har någon annan last samtidigt. En ide kan vara att koppla den till ett 12V batteri, det bör också ge en vettig last.

Share this post


Link to post
Share on other sites

Ok , tack bexander. Ska testa det !

 

Det står följande i manualen, fritt översatt. För att kunna läsa data och konfigurera mikrodatorn måste man ha ett ASCII terminalprogram typ Coolterm eller PuTTY. Inställningar för kommunikation ska vara 115200kbps, 8 data bits, no parity, 1 stop bit.   Har testat med bägge dessa program, knappat in pararmetrar, stoppat usb kabeln in och ut startat om datorn osv. Laddade som tidigare nämnts med en adapterkabel och drivrutin, gick ej.  Kommer bara upp " du har ingen comport på denna dator".

Mvh Pär

Share this post


Link to post
Share on other sites

Ahh, stort tack Kjell :icon_thumbup:  Ska testa detta !!

 

Mvh Pär

Share this post


Link to post
Share on other sites

Hej, lyckades ladda ner den virtuella serieportemulatorn och ladda USB porten med den drivrutinen via devisen manager. 20181205_170334.thumb.jpg.c08093a36c83128cd031dd646f08c25d.jpg

Men icke, CoolTerm hittade inte porten ändå.20181205_170531.thumb.jpg.1546ea0925a87a7a33eeacb1c4e0d84b.jpg

20181205_171103.thumb.jpg.8a6c3c309f03e7ba0acab30d4d93acb1.jpg

Gick då i stället på Arduino spåret och laddade ner hela programpaketet. Och tamefan 😀 Laddade porten med Arduinos drivrutin:20181205_183445.thumb.jpg.8c1f67b4c8f3a27f109dd4c4840b9d6a.jpg

Då minsann ville CoolTerm vara med 👍20181205_183703.thumb.jpg.0c6d647c959e13fc02890c6df2a26f4c.jpg

Verkar som om alla kopplingar, Daisy chain och kontaktorer funkar. Otroligt skönt.  Däremot finns inte programsnutten med accharge med. Mao får inte igång Tcc laddaren via CAN. Får maila Jack på Evtv.

Stort tack Kjell och Bexander för all hjälp och support 😀

Mvh Pär 

  • Like 1

Share this post


Link to post
Share on other sites

Kul att det funkar så långt!

Gällande CAN. Du har inget oscilloskop? Tänker så att du kan kolla om det går någon trafik över CAN eller om det är helt dött?

Bra att mäta resistansen mellan de båda CAN-trådarna. Skall vara 60ohm om allt är korrekt (120ohm i varje ända).

Kan även vara bra att dubbelkolla så att CANH och CANL inte är korsade i kablaget. Alltså CANH skall gå till CANH och CANL till CANL.

  • Like 1

Share this post


Link to post
Share on other sites

Bexander, sitter en LEM spole som mäter strömstyrkan, den är Canbus styrd och fungerar varför det går trafik på bussen. Kontrollerade can h och can l så allt satt på rätt ställe. 

Stoppade i sladden till laddaren och ingenting hände. Fick en felkod att det var unknown command....

Provkörde Foxen med det lilla 48V batteripacket. Ingen bra idé 😨 Efter 100 m eldade jag upp BMS:et.  Borde ha fattat det, 40 A räcker inte långt ( 100m).

Gjorde en bypass på batteriet och körde in i logen. Kablaget glödvarmt.  Var inte någon upphetsande upplevelse, bilen gjorde 50-60 km/h, noll väghållning.  Kommer inte att åka många meter i den......hmmm.

Mvh Pär 

Edited by steel

Share this post


Link to post
Share on other sites

Då känns det som att det är något med CAN-signalerna. Jag gissar att du inte vet vad som skickas men du bör kunna få fram vad laddaren förväntar sig. Dock hjälper inte det om du inte har lämplig utrustning. Du blir nog tvungen att fråga leverantören av systemet. Dock kanske det inte längre är intressant när du släppt ut röken 😞

9 timmar sedan, steel sade:

Var inte någon upphetsande upplevelse, bilen gjorde 50-60 km/h, noll väghållning.  Kommer inte att åka många meter i den......hmmm.

Jag tycker du ser på saken från fel håll. Här finns mycket att förbättra!! Se så, sätt igång! Ge inte upp fören du eldat upp motorn... Jag har dessutom en motsvarande motor på 12kW nyrenoverad liggandes, kan säkert ge ännu mera fart. 

Vad använder du för motorstyrning, visst var det en Kelly Controller? De är tyvärr inte kända för att ha så bra prestanda rent effektmässigt. Jag har själv en delvis uppeldad sådan kontroller liggandes...

Dock kanske bättre att du fokuserar på ElViton om du inte kommer längre här.

Share this post


Link to post
Share on other sites

😀 bexander, så lätt ger jag inte upp 👍 Har ju lite BMW grejer i verkstaden.....

Ger mao upp dc series motorn i Foxen.  Den ska antigen i Gråben eller i en Landrover med tgb11 axlar som påbörjades för många år sedan. Finns nog möjlighet att elda grejer där med ☇ 12 kW är ju 50 % mer effekt !! Det är en Kelly Controller . Men Fox är inrullad i logen bredvid diverse mer eller mindre ofärdiga projekt 🙈

Batteripacket ska igång, ska maila leverantören angående Canbus kommunikationen med laddaren.  Han säljer samma laddare och rekommenderar den till liknande applikation, så det måste gå att få igång på den. 

MEN precis som du skriver kommer energin riktas på Elvito med lite instick på elcross och elcrosskart.

Bände dit nya däck på Elcrossen och bytte en bussning på bakre stötdämparen ikväll. Väntar fortfarande på drev. Får nog snart bli arg 😠 men anlitad mekaniker är en väldigt snäll och försynt människa så det är svårt.

Mvh Pär 

Share this post


Link to post
Share on other sites

Hej, fortsatte med batteripacket. Testade charge enable utgången på mikrodatorn och den funkade.20181208_170403.thumb.jpg.6b59a1080e72033fba4a4b3b3ea061bd.jpg

Satte ett relä som drogs av enable signalen och kopplade laddaren till elcrossen via det relät och tänkte att det måste ju funka. Men icke. 20181208_135822.thumb.jpg.2265faa5a48ab3e0390cb1655c5682e8.jpg

Misstänkte att det var nått tjall med laddaren  då den endast laddade elcross batterierna till 77 V. Och mycket riktigt,  eldat av en av kopplingarna på kretskortet. Hittade en konding som satt lös, kallödning.  Lödde ihop allt och poff !!!😨20181208_135842.thumb.jpg.863accd245a4e6cfdad8045139bea44d.jpg

Så brann det på nästa ställe...lade ner denna verksamhet. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×